[教程] 关于php版本5.3降级还原成5.2.17的方法

  1. wget -c http://dl.wdlinux.cn:5180/soft/php-5.2.17.tar.gz
  2. tar zxvf php-5.2.17.tar.gz
  3. cd php-5.2.17
  4. ./configure –prefix=/www/wdlinux/php-5.2.17 –with-config-file-path=/www/wdlinux/etc –with-mysql=/www/wdlinux/mysql –with-iconv=/usr –with-freetype-dir –with-jpeg-dir –with-png-dir –with-zlib –with-libxml-dir=/usr –enable-xml –disable-rpath –enable-inline-optimization –with-curl –enable-mbregex –enable-mbstring –with-mcrypt=/usr –with-gd –enable-gd-native-ttf –with-openssl –with-mhash –enable-ftp –with-apxs2=/www/wdlinux/apache/bin/apxs
  5. make
  6. make install
  7. rm -f /www/wdlinx/php
  8. ln -s /www/wdlinux/php-5.2.17 /www/wdlinux/php
  9. service httpd restart

很好用,因为php5.3 不支持zend,很多人升级后程序无法运行后悔,这个就是后悔药噢.


逆流成河 » [教程] 关于php版本5.3降级还原成5.2.17的方法
本站部分文章、资源来自互联网,版权归原作者及网站所有,如果侵犯了您的权利,请及时联系我站删除。邮箱:1103606138#qq.com 站点地图